[P&D Module] Created Jobs Placed in 'Other' Department Layer

Incident Report for Northbound Software

Identified

The issue has been identified and a fix is being implemented.
Posted May 05, 2025 - 08:30 CST

Investigating

New jobs that have been created are being placed in the 'Other' Department layer category instead of 'Planning & Development'. Please enable the entire Department layer to view development for both Northbound and client-created jobs at the same time.

All Northbound jobs will remain under the 'Planning & Development' department. We're investigating the possibility of renaming jobs created by clients to another department name instead of 'Other'.
Posted Mar 20, 2025 - 10:56 CST
This incident affects: P&D Module.